Shelly Vintage Lampen

hätte da mal wieder eine Frage. Habe mir mehrere Shelly Vintage gekauft und soweit eingerichtet. Kann sie auch per Smartha App ein/Aus schalten und auch Dimmen. Bauartbedingt musste ich aber auf der CCU 3 CUxD Device anlegen. Einmal CUxD Exec (28) und einmal CUxD Schaltaktor einfach unterputz (40) sowie ein (28) Multi-Dimm-Exec. Mit dem Schaltaktor kann ich die Vintage ein/Aus schalten und mit dem Multi-Dimm-Exec Device die Helligkeit regeln. Klappt ziemlich gut. Ich würde aber gern in dem Shelly Dimm die Shelly Aktoren mit einfügen wollen, so das ich wenn ich Shelly Dimm aufrufe gleich die Vintage einschalten kann und auch Dimmen ohne erst den Umweg wieder zurück in den VG Shelly Lampen zu wechseln. Geht das irgendwie (schon)? Vielen Dank!
PS: ich könnte Theoretisch auch die Vintage hier Ein/Aus schalten, aber sie wird dann nicht Phsysich ausgeschalten sondern regelt nur die Helligkeit auf Null runter. In der WUi bleibt sie an und der Status wird demzufolge auch nicht aktualisiert. Schalte ich sie aber mit den Aktor Ein/Aus, so wird sie tatsächlich ausgeschalten und auch der Status wird richtig angezeigt und aktualisiert . Dies geschieht über die Actions im WUI der Vintage.
PS: ich weiß das ich das über Statusanzeigen machen könnte, würde es aber lieber in der FB der Zentrale machen wollen.

15 (upload://Ac6kZFHmlBfqLoy2A2pj5rk1pfG.jpeg) 16 Screenshot_20201026_164645_com.easysmarthome.cloudmaticapp Screenshot_20201026_164654_com.easysmarthome.cloudmaticapp !Screenshot_20201026_170448_com.easysmarthome.cloudmaticapp

Hi @helind,

wenn es auf der CCU zwei Geräte sind, kannst Du diese leider auch in der Smartha App nicht so zusammenfassen. Du könntest höchstens Dir eine Ansicht erstellen wo diese beiden Geräte drin sind und nebeneinander dargestellt werden.

– Eddy

@Eddy ich danke dir erstmal. Das mit Ansichten funktioniert soweit. Aber ich habe noch ein anderes Problem das ich versuche zu lösen, will aber irgendwie nicht recht klappen. Also ich habe mir einen Schieberegler erstellt und mit diesen kann ich die Helligkeit regeln. Geht ganz gut. Die Anzeige der % stimmt aber nicht. Wenn ich z.B. 40% stelle, wird mir 0,4% angezeigt, bei 100% dann eben 1%.
Kann man das ändern das der tatsächliche Wert angezeigt wird? Also bei 40% dann auch wirklich 40% ?.Desweiteren schiebe ich den Regler nach links/rechts und es ändert sich der Wert. Aber der Regler springt immer wieder auf die Nullposition und nach einer kleinen Denkpause wird dann der Wert aktualisiert. Mir wäre es aber lieb, wenn der Regler aan der entsprechenden Position bleibt und den Richtigen Wert anzeigt. Ist das „nur“ eine Einstellungssache oder funktioniert das so nicht? Wenn nein dann vielleicht in der App ändern, wäre das möglich? Ich hänge mal ein kleines Video mit an.Hier sieht man was ich meine. Vielen Dank schon mal.
Hier ist der Link zum Video > https://youtu.be/uEn-tX9q5YE

Screenshot_20201027_142841_com.easysmarthome.cloudmaticapp Screenshot_20201027_142853_com.easysmarthome.cloudmaticapp Screenshot_20201027_142913_com.easysmarthome.cloudmaticappScreenshot_20201027_181819_com.easysmarthome.cloudmaticapp

Hi @helind,

Du müsstest den Werteformat auf {0} * 100 stellen, damit statt 0.4 - 40 angezeigt wird. Damit sollte der Regler auch nicht mehr zur falschen Stelle springen.

– Eddy

@ Eddy

Oh man, darauf muss man erstmal kommen. Vielen Dank. Funktioniert jetzt und auch der Regler bleibt bei der eingestellten Position stehen. Vorn die Anzeige springt zwar auch erst auf Null und etwa 2 sek. später zeigt es den Richtigen Wert an. Muss wahrscheinlich so sein das er sich erst aktualisieren muss. Habe mir eine Ansicht erstellt und so funktioniert es auch sehr gut. Könnte man eventuell die Höhe noch frei bearbeiten?

PS:habe es nun selbst hinbekommen. Bei An/Aus habe ich die icons angepasst und anstatt 50 nun 55 eingetragen. Siehe da, nun passt es . Vielen Dank für die gute App. Einstellungen sind zwar nicht immer Einfach, aber mit viel Probieren und Geduld kommt man ans Ziel.

Screenshot_20201027_175328_com.easysmarthome.cloudmaticappScreenshot_20201027_194008_com.easysmarthome.cloudmaticapp

1 Like

@ Eddy

irgendwas scheint seit den letzten beiden Updates kaputt gegangen zu sein. Ich kann seitdem nicht mehr mit dem Schieberegler die Vintage steuern. Heißt ich kann zwar schieben, aber er springt immer wieder auf den Wert der in der CCU eingestellt ist zurück. Umgekehrt aber, also wenn ich in der CCU den Schieberegler verändere, ändert er sich auch in der Smartha App. Noch vor paar Tagen funktionierte es aber. Ebenso stürzt die App sofort ab wenn ich einen zweiten Schieberegler (bei einer neu angelegten Shelly Duo, diese kann an/aus, Dimmen und extra noch die Farbtemperatur ändern. Dazu wird ein dritter Kanal dann gebraucht. Habe ich aber in einen anderen Thread schon geschrieben > App stürzt immer ab beim Hinzufügen eines Kanals (System28)

@eschaefer

Ich habe neuerdings das gleiche Problem.Bekannter weise wird die Vintage Lampe in der CCU über CUxD (28) System die Funktion Multi-DIMM-Exec und Geräti-Icon Schaltaktor 1-fach Unterputz hinzugefügt. Das erzeugt 2 Kanäle (siehe Bild oben von helind) Kanal 1 ohne funktion, Kanal 2 Schieberegler und die Schalter über deren „Aus“ man die Lampe direkt auf 0% bzw. über „Ein“ auf 100%.setzt. Die App übernimmt/erstellt 2 Kanäle. Den Kanal 1 aber als Schalter und Kanal 2 über den man den Datenpunkt LEVEL für den Schieberegler auswählen kann. Soweit so gut . Jetzt habe ich aber gesehen das ein betätigen des Schiebereglers auch den Schalter (Kanal1) kurz auslöst und den Schalter der CCU schaltet und den Schieberegler auf 100 % setzt. Umgekehrt Funktioniert es einwand frei.
Und trotz richtig gesetzter Werte habe ich jetzt auch noch eine zusätzliche 100% AnzeigeScreenshot_20201028-223719 .

Hi @Klaus67,

Willkommen im Forum!

Danke für Dein Feedback, bitte schau Dir meinen Beitrag an:

– Eddy

So, ich habe nun meine Duo´s hinzugefügt. Ich kann die Farbtemperatur ändern und auch die Helligkeit.

Aber jetzt habe ich wieder ein anderes Problem, was wahrscheinlich mit den „Richtigen“ Einstellungen in der App leicht zu beheben ist. Ich tue mich aber damit ziemlich schwer.
Also nun wird bei mir nicht mehr der aktuelle Zustand angezeigt. Heißt die Schieberegler bleiben immer ganz links stehen. Schalten/Regeln funktioniert aber. Was ist denn nun schon wieder falsch eingestellt?
Und zweites Problem mit den Einstellungen. Ich hätte gern das die beiden Schieberegler über die Volle Breite sind und unten die Status und Leistungsanzeige ziemlich zentriert sind. Also Am linken Rand etwas frei, dann Leistungsanzeige, wieder etwas frei und Statusanzeige und rechts eben auch etwas frei. Ich bekomme es einfach nicht hin . Das Verhältniss Spalten und Spaltenbreite ist mir noch nicht klar und ich verstehe es einfach nicht. Habe nun schon verschieden Spaltenbreiten probiert, will aber bei mir nicht so recht klappen. Bitte daher nochmal um Unterstützung. Vielen Dank

Screenshot_20201102_175213_com.easysmarthome.cloudmaticapp Screenshot_20201102_175236_com.easysmarthome.cloudmaticapp Screenshot_20201102_175246_com.easysmarthome.cloudmaticapp Screenshot_20201102_175258_com.easysmarthome.cloudmaticapp Screenshot_20201102_175306_com.easysmarthome.cloudmaticapp Screenshot_20201102_175313_com.easysmarthome.cloudmaticapp Screenshot_20201102_175331_com.easysmarthome.cloudmaticapp

Hi @helind,

bei der mathematische Wertemanipulation (Werteformat) musst Du statt geteilt (/), mal (*) rechnen.

Zu der Darstellung: Ich musste die gesamte Definition sehen, um sagen zu können woran das liegt. Vermutlich eine falsche Einstellung der Spalten, Reihe bzw. Spaltenbreite.

– Eddy

Danke. Aktueller Zustand wird jetzt angezeigt.

Darstellung klappt aber noch nicht. Wenn ich 3 Anzeigen einstelle, also ertse Reihe 1, Spalte 0 und Spaltenbreite 12, zweite Reihe dann Reihe 2, 0 12 und dritte Reihe 3, 0 und 12 funktioniert es und die Schieberegler sind über die ganze Breite. Versuche ich aber in Reihe 3 ein Zweites Element zu plazieren, bringt es dann die gesamte Darstellung von allen Elementen Durcheinander.
Lege ich das vierte Element (Onlinstatus) in Reihe 4, 0, 12 ist auch wieder alles ok.
Nur zwei Elemente in einer Reihe bringt alles Durcheinander.

Ich würde schon gern die Zwei Elemente (Leistung und Status) in einer Reihe , zentriert unter den Schiebereglern haben wollen.
Wie sollten denn dann die Einstellungen für Reihe , Spalte und Spaltenbreite sein? Danke

Screenshot_20201102_193600_com.easysmarthome.cloudmaticapp

Hi @helind,

schön, dass es besser wird :slight_smile:

Das erste Element in der dritten Reihe muss 3,0,6 und das Zweite 3,6,6 haben. Wenn Du den Text noch zusätzlich zentriert haben willst, musst Du noch die Ausrichtung auf zentriert stellen.

– Eddy

Vielen Dank Eddy, sieht schon viel besser aus. Noch nicht ganz so wie ich es wollte,aber ist zumindest in einer Reihe und die Schieberegler sind auch groß. Wenn man nun noch links etwas mehr frei hätte, so das das ganze zentrierter aussieht, wäre das schon fast optimal. Bekommt man das noch irgendwie hin? Perfekt wäre es, wenn man selbst die Größe und Plazierung ändern könnte. Ähnlich wie bei den Icons etc. Also sagen wir mal als Beispiel ein Element frei in der Größe 100x 200px (oder eben wie gewünscht) und diese dann noch frei durch verschieben anordnen könnte. So kann man sich ganz auf sich geschnittene FB zusammenstellen

Screenshot_20201102_213222_com.easysmarthome.cloudmaticapp

Hi @helind,

ich habe gerade gesehen, dass die Ausrichtung für das Template „Text“ (was du verwendest) nicht beachtet wird - ich werde das für die nächste Version entsprechend anpassen, so dass das beachtet wird.

Mit den fest eingestellten Pixeln wärst Du an eine Größe gebunden. Mit den Spalten 0-12 skaliert dies entsprechend der Bildschirmgröße. 0 = 0%, 6 = 50%, 12 = 100% der Bildschirmbreite.

– Eddy

1 Like

Damit kann man ja nun was anfangen und versteht den Zusammenhang besser. Es wird also entsprechend skaliert und nicht wie ich erst dachte die Breite aufgeteilt. Vielen Dank.

1 Like