Virtuelle Zentrale Openweather

Moin,
Ich hab eine virtuelle Zentrale via Openweathermap angelegt und würde gern die 3Tage Ansicht (unterer Bereich), mit den Temperaturen und Icons auf dem Grundriss anzeigen.
Ich kann leider immer nur einen Kanal direkt anzeigen und die Icons für die Voraussage gibt es auch nicht als separaten Kanal.

Ich stecke da gerade fest und bekomme es nicht hin. Hat jemand Tipps?

Grüße

HI @Timichino,

Du hast Recht - da hat sich wohl noch ein Fehler eingeschlichen. Die Icons müssen separat verfügbar sein - dies wird nachgeliefert.

Allerdings würden die Icons auch dann nicht angezeigt werden, sondern einfach nur die Icon-URL. Ich werde schauen was ich da machen kann, damit Bild-URLs direkt angezeigt werden.

– Eddy

Hi, danke.
Hatte schon überlegt die Webkachel zu nehmen, man kann aber nicht den Kanal oder eine Variable hinterlegen, nur einen fixen String.
Grüße

Eine Sache hab ich noch.
Man müsste die Aktualisierungshäufigkeit für die API einstellen können.
Dadurch, dass der Display always On ist komme ich am Tag über die 1000 API Calls und werde mit Mails seitens Openweather zum Kauf „verführt“.
Grüße

1 Like

Hallo @Timichino,

Danke für Dein Feedback - Du hast Recht - derzeit wird 1 Aufruf pro Minute durchgeführt. Das macht 1440 Aufrufe pro Tag. Gerne habe ich den Vorschlag aufgenommen das einstellbar zu machen.

– Eddy

Moin, ich habe seit dem Update nun mehr Zeit gehabt die Werte zu beobachten.
Anscheinend werden nicht mehr alle Werte korrekt synchronisiert.
Zum Beispiel sind Icons für die Vorhersagen ab Tag 2 immer die Gleichen. Nur für den aktuellen Tag scheint dir korrekte gezogen zu werden.
Es fehlen auch jede Menge Datenpunkte für den aktuellen Tag. Bild anbei.
Vor dem Update waren alle Datenpunkte vorhanden…Screenshot_20201018-224822
Hat Openweathermap was umgestellt?

Grüße

Hi @Timichino,

hm, es scheint als konnten die Daten nicht abgerufen werden. Könntest Du versuchen das virtuelle Gerät neu anzulegen und/oder das Log nach einem Abruf zusenden?

– Eddy

Moin, neu angelegt und danach eine Vollsynchro gemacht. Log ist raus.

Grüße