Neues Beta-Modul zum Testen: Shelly

Hallo zusammen,

wie versprochen gibt es heute die erste Beta-Version des Shelly-Modules :partying_face:

Folgende Shelly Geraete sind bereits implementiert (und z.T. auch schon getestet):

  • Shelly 1
  • Shelly 1PM
  • Shelly 1L
  • Shelly Motion
  • Shelly Plug
  • Shelly Plug S
  • Shelly Button 1 (SHBTN-1 & SHBTN-2)

Weitere Geraete werden in den kommenden Wochen folgen.

Das Modul laesst sich ueber die UI ueber „Einstellungen“ → „Module“ → „Modul hinzufuegen“ installieren. Anschliessend koennen die Shelly’s als Geraet ueber „Inventar“ → „Geräte“ → „Gerät hinzufügen“ installiert werden.

Bitte fuehrt vor der Installation des Modules eine Systemaktualisierung eurer smartha Home Zentrale durch!

Wichtig: Damit die Shelly’s mit dem Modul funktionieren muessen ein paar Einstellungen auf den Geraeten vorgenommen werden!

Zuallererst sollte die Firmware des Geraetes auf die aktuellste Version aktualisiert werden.

Das Modul kommuniziert ueber das CoIoT-Protokoll mit den Geraeten, daher muss jeweils unter „Internet & Security“ → „Advanced - Developer Settings“ „Enable CoIoT“ aktiviert werden. Weiterhin muss unter „CoIoT peer“ die IP-Adresse eurer smartha plus Port (5683) angegeben werden:
FireShot Capture 1432 - Shelly Plug - 192.168.111.75

Diese Einstellung ist noetig, da Multicast in naher Zukunft seitens Shelly-Firmware deaktiviert werden wird (bei einigen Devices ist das schon der Fall).

Sobald die Suche nach Geraeten ueber die smartha gestartet worden ist, „lauscht“ diese eine Minute lang nach Paketen der Shelly’s im Netzwerk. Bei batteriebetriebenen Geraeten muss innerhalb dieses Zeitraumes eine Aktion ausgeloest werden (beim Button z.B. ein kurzer Tastendruck), damit ein Paket gesendet wird.

Es sind noch nicht alle Frontend-Visualisierungen fertig, da wir nicht alle Shelly Geraete vor Ort zum Testen hatten. Ihr koennt mir in dem Fall gerne die benoetigte JSON-Datei per PM schicken, dann koennen wir die Visualisierung erstellen :wink:

Viel Spass beim Testen, und wir freuen uns auf euer Feedback :star_struck:

– Micha

Nachtrag: Dieses Modul wird „nur“ die Gen-1 Shelly’s enthalten. Fuer die neuen „Pro“ Geraete wird es ein eigenes Modul geben!

3 Like

Hallo Micha,
ich habe das Test Modul eingebaut. So weit so gut.
Ich sende die fĂĽr Shelly 1, Shelly 1PM die einzeln Layout files.

Ich habe eine Frage zur Programmierung.
Ihr habt schon eine interne Umsetzung damit der Switch per true bzw false reagiert. So gibt das debug aus und steht auch in der DB als Eintrag.
Das sieht auch ok aus wenn ich vom Shelly schalte.
grafik
Aber wenn ich ein True oder false sende bekomme ich die Fehlermeldung:

„Error setting variable (Peer ID: 332, channel: 1, name: STATE): Unknown application error.“

Volker

Hach. Ich kann es leider nicht wirklich nutzen, da ich meinen Shelly in einem anderen Netzwerk habe, wie meine Smartha. Und so sieht die Smartha wohl nicht die entsprechenden Pakete des Shellys… -.-

Huhu @leika241265,

schauen wir uns an, danke :wink:

– Micha

Sehr genial!
Freu mich drauf!
Bin ja leider kein Beta.
Sollte ich wechseln?

Hi @mexx.111,

„wechseln“ von einer Stable smartha Home auf eine Beta geht leider nicht.
Du koenntest die die OpenBeta parallel auf einem Pi installieren, und so das neue Modul testen.

– Micha

Danke Micha,

Das wäre eine Möglichkeit. Die Hardware schwirrt hier irgendwo rum…

Aber ich denke, ich werde die paar Tage/Wochen noch warten.
Meine Shellys liegen eh schon eine ganze weile hier rum, und bauen sich nicht von selbst ein!

Wie ist es denn mit den Modulen fĂĽr den Shelly 1?
Laufen die auch?

Hi @mexx.111,

der Shelly 1 ist auch mit drin (siehe Liste oben). Allerdings gibt es da noch einen Bug …

– Micha

Danke Micha,

Ich meinte aber die Aufsatzmodule fĂĽr den Shelly 1.
Also das Temperaturaddon vor allem!
Die Schalter(Magnet, Infrarot,…) werden nicht das Problem sein, damit wird wahrscheinlich True/False ausgegeben.

lg

Hey @mexx.111,

theoretisch sollte das funktionieren, mangels Hardware konnten wir es nur „blind“ implementieren :thinking:

– Micha

Hallo zusammen,

ein neues Update ist verfuegbar. Es gibt (noch) keine neuen Geraete, aber einen Bugfix:

  • Aktivierte Authentifizierung der Shelly-Geraete funktioniert nun

– Micha

Hallo Micha,
ist das Update denn schon veröffentlich und zugängig?
Volker

Hey @leika241265,

mittlerweile ja … da hing was im Git fest :grimacing:

– Micha

Hi Micha,
muss noch zum Update etwas geändert werden weil trotz Update es nicht geht.

Kommt immer noch:
„Error setting variable (Peer ID: 332, channel: 1, name: STATE): HTTP error: Unable to read from HTTP server „xxxx“: Server requires authentication.“

Ohne „authentication“ geht es natürlich.

UI-Version 0.2.0-1316-beta
Version 0.8.0-3331

Volker

Hi @leika241265,

du musst bei dem entsprechenden Geraet im Admin-Bereich unter „Konfigurationsparameter bearbeiten“ Username und Password eintragen :wink:

– Micha

Hi Micha,
dann klappt es auch. Hatte mich schon gewundert wie das ohne Username und Password gehen sollte. :+1: :grinning:

So, alle meine Geräte kann ich nun schalten.

Volker

3 Like

Hallo zusammen,

es gibt ein neues Update des Modules … folgende Geraete wurden neu implementiert:

  • Shelly Bulb (SHBLB-1)
  • Shelly Vintage (SHVIN-1)
  • Shelly Duo (SHBDUO-1)
  • Shelly Bulb RGBW (SHCB-1)
  • Shelly RGBW2 Color (SHRGBW2-color)
  • Shelly RGBW2 White (SHRGBW2-white)

Viel Spass :wink:

– Micha

Hallo Micha,
hier eine Layout Datei fĂĽr :
Shelly Bulb RGBW
SHCB-1.json (5,5 KB)

Hallo Micha,
sieht alles Top aus. Auch die Funktionen klappen aus der Ansicht und auch aus einem flow.

grafik

Das ermöglich viele Möglichkeiten. Echt cool.
Ich kann noch die Smartha App testen aber das Layout in noch nicht vorhanden.
Da warte ich mal die nächste beta ab.

:+1: :+1:

2 Like

Sehr schick!

Sry, hatte gestern ganz vergessen das Update zu posten :grimacing:

– Micha